STM32L432 Nucleo 32 board

Topics that are related to specific development boards (mbed, LPCXpresso, Embedded Artists, Olimex, Coridium, StarterKit, NGX Technologies, EzSBC etc)

STM32L432 Nucleo 32 board

Postby preston » Sat Oct 28, 2017 5:22 am

So, I have one of these handy boards
and I can connect it to Astrobe on a PC via a USB cable,
download the blinking lights program
and make the LED blink. I can even adjust the pattern
so I know it's running my code and not someone else's.
Furthermore, I can plug the USB cable into other machines
and the board will wake up and run my little program.

Great!

Now I'd like to run the board & my program without the USB connected.
So, I connect 5V and ground, and the power LED comes on
but the user LED doesn't blink.
Pressing the reset button doesn't help.
And I've run out of things to try...

How do I get it to run the program that living there in the flash memory?
(short of powering it via the USB)

Thanks,
Preston
preston
 
Posts: 5
Joined: Sat Oct 21, 2017 12:06 am
Location: Seattle

Re: STM32L432 Nucleo 32 board

Postby cfbsoftware » Sat Oct 28, 2017 6:43 am

I've just tried it with 3 x 1.5v batteries connected to +5V (CN4-4) and had the same problem. My multimeter read 4.85 volts which should be OK.

I also tried with a 9V battery connected to VIN (CN4-1) and that worked as expected. When it does work the ST_Link LED also flashes red.
cfbsoftware
Site Admin
 
Posts: 299
Joined: Fri Dec 31, 2010 12:30 pm

Re: STM32L432 Nucleo 32 board

Postby preston » Sat Oct 28, 2017 9:07 pm

Thanks. Driving Vin works for me too, even with 5V.
I eventually found some discussion online, https://os.mbed.com/questions/68476/Nucleo-F303K8-fails-to-start-program-whe/.

Preston
preston
 
Posts: 5
Joined: Sat Oct 21, 2017 12:06 am
Location: Seattle


Return to Development Boards

cron